rbenvで2.0.0系のrubyインストール時のエラーの改善方法メモ

rubyのバージョンを2系にしないとrails 4系は動作しないらしい。
改善としてはrubyのバージョンを2系にするかrailsをダウングレードするかのみ。
今回はxcodeのバージョンをアップしていない(OSアップデートしていない)ため
railsのダウングレードをする

Warning: You're using Rubygems 1.8.23 with Spring. Upgrade to at least Rubygems 2.1.0 and run `gem pristine --all` for better startup performance.
* bin/rake: spring inserted
* bin/rails: spring inserted

Railsダウングレード

一度対象のRailsをアンインストールし再度バージョンを指定してRailsのインストールで完了

Railsアンインストール

gem uninstall railties -v '4.1.1'

※アンインストールバージョンが4.1.1の場合

Railsバージョン指定インストール

sudo gem install rails -v '3.2.10'

※インストールバージョンが3.2.10の場合

その他おすすめの備忘録

Tagged with:
 

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

次のHTML タグと属性が使えます: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>